Тема №12006 Ответы к тестам по информатике 10 тем (Часть 1)
Поиск задачи:

Рассмотрим тему Ответы к тестам по информатике 10 тем (Часть 1) из предмета Информатика и все вопросы которые связанны с ней. Из представленного текста вы познакомитесь с Ответы к тестам по информатике 10 тем (Часть 1), узнаете ключевые особенности и основные понятия.

Уважаемые посетители сайта, если вы не согласны с той информацией которая представлена на данной странице или считаете ее не правильной, не стоит попросту тратить свое время на написание негативных высказываний, вы можете помочь друг другу, для этого присылайте в комментарии свое "правильное" решение и мы его скорее всего опубликуем.


Обучающие и тренировочные тестовые задания уровня сложности А
Тема 1. Информация и сообщения
1.    Выберите верное утверждение:
а)    2,5 кб = 2500 байт
б)    5000 байт = 5 кб
в)    5120 кб = 5 Мб
г)    8000 бит = 1 кб
д)    1 кб = 1000 байт
2.    Слово «Информатика» (без кавычек) в ЭВМ кодируется по принципу «1 символ – 1 байт» битовой информацией длины …
а)    8
б)    16
в)    32
г)    88
д)    191
3.    Для кодировки битами до 31 различного цвета достаточна битовая комбинация длины …
а)    30
б)    16
в)    8
г)    5
д)    2
4.    Укажите неверное утверждение:
а)    2 Гб = 2 000 000 кб
б)    5 кб > 5000 байт
в)    100 Мб < 0,1 Гб
г)    56 бит > 6 байт
д)    1 бит = 0 или 1
5.    Уравнение вида 1 кб = 102  х + 4 байта имеет решение…
а)    х = 1
б)    х = 5
в)    х = 10
г)    х = 16
д)    х = 19
6.    Информация обладает свойством…
а)    полноты
б)    абсолютности
в)    всеобщности
г)    старости
д)    рекламирования
7.    Объем сообщений в 1 Гб меньше, чем в …
а)    1000 Мб
б)    1 000 000 кб
в)    10 000 000 000 байтах
г)    8 000 000 000 битах
д)    100 000 байтах
8.    В ASCII-коде предложения вида «Информационный запрос» (без учета кавычек) число различных байтов равно …
а)    21
б)    20
в)    15
г)    14
д)    10
9.    Количество одинаковых символов в битовом сообщении 11110000101010000111100110011110110100001111111111110001, закодированном по принципу «1 байт – 1 символ», равно …
а)    4
б)    3
в)    2
г)    1
д)    0
10.    Количество различных чисел, кодируемых 11 битами, равно
а)    11 000
б)    10 000
в)    2048
г)    1025
д)    11
Тема 2. Системы счисления
1.    Десятичное число 1025 равно двоичному числу…
а)    10000000001
б)    100000000000
в)    11000000000
г)    10000100001
д)    10000000000
2.    Десятичное число 449 равно восьмеричному числу…
а)    187
б)    765
в)    781
г)    701
д)    791
3.    Десятичное число 999 равно шестнадцатеричному числу…
а)    3Е7
б)    3В7
в)    7Е3
г)    7С3
д)    FFF
4.    Двоичное число 11100100001 равно восьмеричному числу…
а)    3441
б)    7142
в)    6461
г)    6714
д)    7707
5.    Двоичное число 1110011001110 равно шестнадцатеричному числу…
а)    3СВ1
б)    ССС1
в)    1ССЕ
г)    6ССВ
д)    АВ19
6.    Восьмеричное число 343 равно двоичному числу…
а)    11100011
б)    10111101
в)    1110001
г)    10111001
д)    10000000
7.    Шестнадцатеричное число С3А9 равно двоичному числу…
а)    1100001110101001
б)    1111100000111101
в)    1110111100000001
г)    1101110000001001
д)    1101011011011101
8.    Сумма двоичных чисел 11101,10 и 111,111 равна двоичному числу…
а)    101000,011
б)    101110,010
в)    1000101,011
г)    111110,111
д)    100010,101
9.    Сумма восьмеричных чисел 10,47 и 74,53 равна восьмеричному числу…
а)    105,22
б)    220,22
в)    202,22
г)    222,02
д)    245,11
10.    Сумма шестнадцатеричных чисел АВ,В2 и 5F,E9 равна шестнадцатеричному числу…
а)    10B,9B
б)    F5,AB
в)    10B,AB
г)    AB,AB
д)    DA,19
Тема 3. Высказывания, предикаты, логические функции
1.    В списке выражений вида:
1)    2-2=0
2)    2+3=6
3)    3+12
4)    2+2>2+2
5)    2-0=3-0
6)    56=50+6
приведено всего истинных и ложных высказываний соответственно:
а)    2, 3
б)    2, 2
в)    3, 2
г)    3, 3
д)    1, 4
2.    Если значения x, y принадлежат отрезку [2; 5], то в списке выражений следующего вида:
1)    х=2 или у=7
2)    x-y
3)    x+y<2
4)    x2+5=0
5)    3<x<y<5
6)    x>12
число истинных и ложных предикатов соответственно равно…
а)    2, 4
б)    1, 4
в)    3, 3
г)    1, 5
д)    2, 3
3.    Выражение z = x /\ (y \/ x) \/ x после применения аксиом алгебры предикатов и высказываний запишется наиболее кратко в виде:
а)    x
б)    y
в)    x /\ y
г)    x \/ y
д)    1
4.    Выражение (x \/ y) \/ x после применения аксиом алгебры предикатов и высказываний запишется наиболее кратко в виде:
а)    x
б)    y
в)    x
г)    y
д)    0
5.    Множество истинности предиката р(х) = «х + у = 0», где х, у – целые числа принадлежат отрезку [-2; 4], равно …
а)    {–2, –1, 1, 2}
б)    {(–2, 2), (-1, 1)}
в)    {(–2, 2), (-1, 1), (0,0)}
г)    [–2, 2]
д)    [-1, 1]
6.    Высказыванием является предложение вида …
а)    «климат теплый»
б)    «климат местами теплый, местами – холодный»
в)    «1+2»
г)    «1+2=4»
д)    31 декабря»
7.    Для предиката р(х): «div(х, 3) = mod(x, 2)», где х изменяется на множестве Х={2, 3, 5, 10, 19}, область истинности равна…
а)    {2, 3, 5, 10}
б)    {10, 19}
в)    {2, 3, 5}
г)    {2, 5, 10}
д)    {5}
8.    Верно следующее утверждение:
а)    основание системы = максимальная цифра в системе
б)    основание системы = максимальная цифра в системе + 1
в)    основание системы = максимальная цифра в системе – 1
г)    основание системы = количество различных чисел в ней
д)    основание системы = сумма используемых в ней цифр
9.    Выражение (х \/ у /\ х) /\ (х \/ у) \/ х после последовательного применения всех подходящих аксиом алгебры высказываний и предикатов примет окончательный вид…
а)    у /\ х \/ х
б)    х \/ у
в)    у /\ х
г)    1
д)    0
10.    Выражение ((х \/ у) /\ х \/ у) /\ ((х /\ у) \/ х) после последовательного применения всех подходящих аксиом алгебры высказываний и предикатов примет окончательный вид…
а)    у /\ х  \/ х
б)    х \/ у
в)    х /\ у
г)    0
д)    1
Тема 4. Алгоритмы и алгоритмизация
1.    После выполнения фрагмента алгоритма вида:
s:=0
i:=1
нц пока (i<4)
    i:= i+1
s:= s+1
кц
значение переменной s равно…
а)    0
б)    3
в)    5
г)    9
д)    11
2.    Фрагмент алгоритма вида:
y:=0
x:=12345
нц для I от 1 до 4
y:= y + mod (x,10)
x:= int (x/10)
кц
вычисляет значение переменной у, равное:
а)    12
б)    13
в)    14
г)    15
д)    16
3.    Фрагмент алгоритма вида:
k:=1
s:= x[1]
нц для i от 1 до n
если (s<x[i])
то s:=x[i]
k:=i
все
кц
вывод (k)
выводит значение переменной k, равное…
а)    максимальному элементу массива чисел х[1], x[2], …, x[n]
б)    сумме элементов х[1], x[2], …, x[n] меньших, чем х[1]
в)    индексу максимального элемента ряда х[1], x[2], …, x[n]
г)    индексу минимального элемента ряда
д)    последнему значению i
4.    Фрагмента алгоритма вида:
s:=0
i:=1
нц пока (i<1000)
s:=s+x[i]
i:=i+2
кц
находит сумму чисел ряда…
а)    х[1], x[2], x[3], …, x[999]
б)    х[1], x[3], x[5], …, x[999]
в)    х[1], x[3], x[5], …, x[1000]
г)    х[2], x[4], x[6], …, x[9999]
д)    х[1], x[2], x[5], …, x[1000]
5.    Фрагмента алгоритма вида:
p:=1
нц для i от 1 до int(n/2)
p:= p*x[i]
кц
находит произведение всех чисел…
а)    ряда х[1], x[2], …, x[n]
б)    ряда х[1], x[2], …, x[n], которые являются целыми
в)    второй половины ряда х[1], x[2], …, x[n]
г)    первой половины ряда х[1], x[2], …, x[n]
д)    кратных двум
6.    Значение переменной р после выполнения фрагмента алгоритма вида:
p:=1
i:=4
нц пока (i>0)
p:=p*i
i:=i-1
кц
равно…
а)    1
б)    12
в)    24
г)    120
д)    156
7.    Фрагмента алгоритма вида:
b:=abs (b)
нц пока ((a>0) и (b>0)
если (a>b)
то a:=mod(a,b)
иначе b:=mod(b,a)
все
кц
f:=a+b
определит значение переменной f=1 при значениях:
а)    a=0; b=2
б)    a=2; b=0
в)    a=14; b= –3
г)    a=2; b= –2
д)    a= –1; b= –1
8.    Фрагмент алгоритма вида:
i:=1
j:=1
s:=0
нц пока ((i<n) и (x[i,j]>0))
j:=1
 (x[i,j]>0))
s:=s+x[i,j]
j:=j+1
кц
i:=i+1
кц
для заданного массива x[1:n, 1:m] находит сумму s …
а)    всех положительных элементов массива
б)    положительных элементов массива до первого неположительного
в)    всех отрицательных элементов массива
г)    положительных четных элементов массива
д)    положительных чисел, меньших m
9.    Из списка команд:
1)    нц пока (i<n)
2)    m:=x[1]
3)    если (m>x[i]) то m:=x[i]
4)    i:=i+1
5)    кц
6)    i:=1
тело программы поиска минимума ряда x[1:n] можно скомпоновать в порядке:
а)    6, 2, 1, 3, 4, 5
б)    6, 3, 4, 2, 1, 5
в)    6, 1, 3, 2, 4, 5
г)    6, 3, 1, 5, 4, 2
д)    6, 1, 3, 4, 2, 5
10.    Команда вставки в текст t текста p вместо подтекста от позиции номер n до позиции номер m имеет вид:
а)    t:=t[1:n]+p+t[n:длина(t)]
б)    t:=t[1:n]+t[m:длина(t)]+p
в)    t:=t[1:n–1]+p+t[m+1:длина(t)]
г)    t:= t[1:n–1]+ t[m+1:длина(t)]+p
д)    t:= t[1:p]+n+t[p:длина(t)]
Тема 5. Данные к алгоритмам и исполнители алгоритмов
1.    В результате выполнения команды вида:
a:=sign(2) + int(2,6)  div(6,4) + mod(1,3)  sing(pi–4) – 1/2,5/sgrt(0,16)
значение переменной a будет равно…
а)    3
б)    2
в)    1
г)    0
д)    –1
2.    Из списка файлов вида:
1)    p1.doc
2)    p2.exe
3)    p3.zip
4)    p4.txt
можно сразу запустить на выполнение содержимое файла…
а)    p1
б)    p2
в)    p3
г)    p4
д)    p1 и p3
3.    Из списка файлов вида:
1)    p1.doc
2)    p2.exe
3)    p3.zip
4)    p4.txt
можно распаковывать архиватором содержимое файла…
а)    p1
б)    p2
в)    p3
г)    p4
д)    p1 и p4
4.    Из списка файлов вида:
1)    p1.doc
2)    p2.exe
3)    p3.zip
4)    p4.rtf
сразу открыть и прочитать документ в Word можно из следующих файлов…
а)    p1, p2
б)    p1, p3
в)    p3, p4
г)    p1, p4
д)    p2, p3
5.    Из списка файлов вида:
1)    p1.doc
2)    p2.xls
3)    p3.zip
4)    p4.tab
электронную Excel–таблицу содержит только файл…
а)    p1
б)    p2
в)    p3
г)    p4
д)    p2 и p3
6.    Выполнение команды вида:
a:=int(–5,19) + abs(–3)  mod(7,3) – max(mod(12,5),div(32,3))  sqrt(0.01);
определит значение переменной a, равное…
а)    6
б)    4
в)    –4
г)    –6
д)    –10
7.    Последовательное выполнение двух команд вида:
a:=abs(–5) + int(pi)  mod(11,1);
a:=max(a, div(a,3))  int(a/2) + sqrt(a+4)
определит значение переменной a, равное:
а)    18
б)    13
в)    11
г)    10
д)    9
8.    Исполнителем алгоритмов не может быть только…
а)    компьютер
б)    человек
в)    автомат
г)    файл
д)    Лого-система
9.    Любой исполнитель алгоритмов должен иметь в своем составе…
а)    операционную среду
б)    операционную систему
в)    оперативный простор
г)    оперативную память
д)    оперативную карту
10.    Наиболее верна символическая формула…
а)    «Программа = Алгоритм + Структура данных»
б)    «Алгоритм = Программа + Структура данных»
в)    «Программа = Исполнитель + Язык программирования»
г)    «Структура данных = Язык программирования + Числа»
д)    «Программа – Алгоритм = Структура данных»
 

 

Таблица ответов к тестовым заданиям группы А

Номер и наименование темы

1

2

3

4

5

6

7

8

9

10

Тема 1. Информация и сообщения

в

г

г

а

в

а

в

в

б

в

Тема 2. Системы счисления

а

г

а

а

в

а

а

в

а

а

Тема 3. Высказывания, предикаты, логические функции

а

б

а

в

в

г

в

б

а

в

Тема 4. Алгоритмы и алгоритмизация

г

в

в

б

г

в

в

б

а

в

Тема 5. Данные к алгоритмам и исполнители алгоритмов

в

б

в

г

б

в

б

г

а

а

Тема 6. Программные системы

г

г

а

в

б

а

а

б

а

б

Тема 7. Компьютер, компьютерные системы и сети

в

г

г

г

в

г

а

в

в

г

Тема 8. Новые информационные технологии

в

г

в

а

г

а

г

а

б

а

Тема 9. Математическое и компьютерное моделирование

а

г

г

в

а

а

в

б

а

б

Тема 10. Программирование на языке Паскаль

г

а

в

в

а

б

г

г

б

в


Категория: Информатика | Добавил: (26.10.2017) Просмотров: | Рейтинг: 0.0/0

Другие задачи:
Всего комментариев: 0
avatar