Задача №4916

Задания B14 по информатике с ответами

Поиск задачи:

Здесь представлено решение задачи по информатике. Если у вас возникли сложности в решении то вы можете воспользоваться ответами которые размещены на данной странице. Вы конечно можете не согласиться с ответами, но данная информация размещена с целью ознакомления. Списывать с ответов или решать самому выбирать вам. Данная задача по теме ЕГЭ
Решение задачи:

Уважаемые посетители сайта, если вы не согласны с той информацией которая представлена на данной странице или считаете ее не правильной, не стоит попросту тратить свое время на написание негативных высказываний, вы можете помочь друг другу, для этого присылайте в комментарии свое "правильное" решение и мы его скорее всего опубликуем.

Условие задачи:


Задания B14 по информатике
1. Сколько различных решений имеет система уравнений
¬(x1 ≡ x2) /\ ¬(x2 ≡ x3) =1
¬(x2 ≡ x3) /\ ¬(x3 ≡ x4) =1
...
¬(x8 ≡ x9) /\ ¬(x9 ≡ x10) =1
где x1, x2, ..., x10 – логические переменные?
В ответе не нужно перечислять все различные наборы значений x1, x2, ..., x10, при
которых выполнена данная система равенств. В качестве ответа вам нужно указать
количество таких наборов.
Ответ: 2
2. Сколько различных решений имеет система уравнений
¬(x1 ≡ x2) /\ ¬(x2 ≡ x3) =1
¬(x2 ≡ x3) /\ ¬(x3 ≡ x4) =1
...
¬(x7 ≡ x8) /\ ¬(x8 ≡ x9) =1
где x1, x2, ..., x9 – логические переменные?
В ответе не нужно перечислять все различные наборы значений x1, x2, ..., x9, при
которых выполнена данная система равенств. В качестве ответа вам нужно указать
количество таких наборов.
Ответ: 2

3. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен н а четырех
языках):
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -20: B = 20
T = A: M = A: R = F(A)
FOR T = A TO B
IF F(T) < R THEN
M = T
R = F(T)
ENDIF
NEXT T
PRINT M
FUNCTION F(x)
F = 2*(x-9)*(x-9);
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 2*(x-9)*(x-9);
end;
BEGIN
a := -20; b := 20;
M := a; R := F(a);
for t := a to b do
if (F(t)<R) then begin
M := t;
R := F(t);
end;
write(M);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 2*(x-9)*(x-9);
}
void main()
{
int a, b, t, M, R;
a = -20; b = 20;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t)<R) {
M = t; R = F(t);
}
}
printf("%d", M);
}
алг
нач
цел a, b, t, R, M
a := -20; b := 20
M := a; R := F(a)
нц для t от a до b
если F(t)< R
то
M := t; R := F(t)
все
кц
вывод M
кон
алг цел F(цел x)
нач
знач := 2*(x-9)*(x-9)
кон
Ответ: 9

4. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырех
языках):
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -20: B = 20
T = A: M = A: R = F(A)
FOR T = A TO B
IF F(T) < R THEN
M = T
R = F(T)
ENDIF
NEXT T
PRINT M
FUNCTION F(x)
F = 2*(x-19)*(x-19)+7;
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 2*(x-19)*(x-19) + 7;
end;
BEGIN
a := -20; b := 20;
M := a; R := F(a);
for t := a to b do begin
if (F(t)<R) then begin
M := t;
R := F(t);
end;
end;
write(M);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 2*(x-19)*(x-19)+7;
}
void main()
{
int a, b, t, M, R;
a = -20; b = 20;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t)<R) {
M = t; R = F(t);
}
}
printf("%d", M);
}
алг
нач
цел a, b, t, R, M
a := -20; b := 20
M := a; R := F(a)
нц для t от a до b
если F(t)< R
то
M := t; R := F(t)
все
кц
вывод M
кон
алг цел F(цел x)
нач
знач := 2*(x-19)*(x-19)+7
кон
Ответ: 19

5. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках программирования).
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A 3: B 25
M A: R F(A)
FOR T A TO B
IF F(T) < R THEN
M T
R F(T)
END IF
NEXT T
PRINT R
FUNCTION F(x)
F 6*(13+x)*(13+x)+127
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F : 6*(13+x)*(13+x)+127;
end;
BEGIN
a : 3; b : 25;
M : a; R : F(a);
for t : a to b do begin
if (F(t) < R) then begin
M : t;
R : F(t);
end;
end;
write(R);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 6*(13+x)*(13+x)+127;
}
void main()
{
int a, b, t, M, R;
a 3; b 25;
M a; R F(a);
for (t a; t< b; t++){
if (F(t) < R) {
M t; R F(t);
}
}
printf("%d", R);
}
алг
нач
цел a, b, t, R, M
a : 3; b : 25
M : a; R : F(a)
нц для t от a до b
если F(t) < R
то
M : t; R : F(t)
все
кц
вывод R
кон
алг цел F(цел x)
нач
знач : 6*(13+x)*(13+x)+127
кон
Ответ: 727

6. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках программирования).
Бейсик
Паскаль
DIM A, B, T, M, R AS INTEGER
A 7: B 25
M A: R F(A)
FOR T A TO B
IF F(T) < R THEN
M T
R F(T)
END IF
NEXT T
PRINT R
FUNCTION F(x)
F 214 + 3*(17+x)*(17+x)
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F : 214 + 3*(17+x)*(17+x);
end;
BEGIN
a : 7; b : 25;
M : a; R : F(a);
for t : a to b do begin
if (F(t) < R) then begin
M : t;
R : F(t);
end;
end;
write(R);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 214 + 3*(17+x)*(17+x);
}
void main()
{
int a, b, t, M, R;
a 7; b 25;
M a; R F(a);
for (t a; t< b; t++){
if (F(t) < R) {
M t; R F(t);
}
}
printf("%d", R);
}
алг
нач
цел a, b, t, R, M
a : 7; b : 25
M : a; R : F(a)
нц для t от a до b
если F(t) < R
то
M : t; R : F(t)
все
кц
вывод R
кон
алг цел F(цел x)
нач
знач : 214 + 3*(17+x)*(17+x)
кон
Ответ: 514

7. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на
четырёх языках):
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = –21: B = 21
M = A: R = F(A)
FOR T = A TO B
IF F(T) > R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT M
FUNCTION F(x)
F = 12 *(9+x)*(9+x)+7
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 12*(9+x)*(9+x)+7;
end;
BEGIN
a := –21; b := 21;
M := a; R := F(a);
for t := a to b do begin
if (F(t) > R) then begin
M := t;
R := F(t);
end;
end;
write(M);
END.
Си Алгоритмический
#include <stdio.h>
int F(int x)
{
return 12*(9+x)*(9+x)+7;
}
void main()
{
int a, b, t, M, R;
a = –21; b = 21;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) > R) {
M = t; R = F(t);
}
}
printf("%d", M);
}
алг
нач
цел a, b, t, R, M
a := –21; b := 21
M := a; R := F(a)
нц для t от a до b
если F(t) > R
то M := t; R := F(t)
все
кц
вывод M
кон
алг цел F(цел x)
нач
знач := 12 *(9+x)*(9+x)+7
кон
Ответ: 21

8. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на
четырёх языках):
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -25: B = 25
M = A: R = F(A)
FOR T = A TO B
IF F(T) > R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT M
FUNCTION F(x)
F = 19*(4+x)*(4+x)+ 52
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 19*(4+x)*(4+x)+52;
end;
BEGIN
a := -25; b := 25;
M := a; R := F(a);
for t := a to b do begin
if (F(t) > R) then begin
M := t;
R := F(t);
end;
end;
write(M);
END.
Си Алгоритмический
#include <stdio.h>
int F(int x)
{
return 19*(4+x)*(4+x)+52;
}
void main()
{
int a, b, t, M, R;
a = -25; b = 25;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) > R) {
M = t; R = F(t);
}
}
printf("%d", M);
}
алг
нач
цел a, b, t, R, M
a := -25; b := 25
M := a; R := F(a)
нц для t от a до b
если F(t) > R
то M := t; R := F(t)
все
кц
вывод M
кон
алг цел F(цел x)
нач
знач := 19*(4+x)*(4+x)+ 52
кон
Ответ: 25

9. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках):
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -20: B = 20
M = A: R = F(A)
FOR T = A TO B
IF F(T) < R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT M
FUNCTION F(x)
F = 19*(16-x)*(16-x)+27
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 19*(16-x)*(16-x)+27;
end;
BEGIN
a := -20; b := 20;
M := a; R := F(a);
for t := a to b do begin
if (F(t) < R) then begin
M := t;
R := F(t);
end;
end;
write(M);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 19*(16-x)*(16-x)+27;
}
void main()
{
int a, b, t, M, R;
a = -20; b = 20;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) < R) {
M = t; R = F(t);
}
}
printf("%d", M);
}
алг
нач
цел a, b, t, R, M
a := -20; b := 20
M := a; R := F(a)
нц для t от a до b
если F(t) < R
то
M := t; R := F(t)
Все кц вывод M
кон
алг цел F(цел x)
нач знач := 19*(16-x)*(16-x)+27
кон
Ответ: 16

10. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках):
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -20: B = 20
M = A: R = F(A)
FOR T = A TO B
IF F(T) < R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT R
FUNCTION F(x)
F = 19*(11-x)*(11-x)+27
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 19*(11-x)*(11-x)+27;
end;
BEGIN
a := -20; b := 20;
M := a; R := F(a);
for t := a to b do begin
if (F(t) < R) then begin
M := t;
R := F(t);
end;
end;
write(R);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 19*(11-x)*(11-x)+27;
}
void main()
{
int a, b, t, M, R;
a = -20; b = 20;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) < R) {
M = t; R = F(t);
}
}
printf("%d", R);
}
алг
нач
цел a, b, t, R, M
a := -20; b := 20
M := a; R := F(a)
нц для t от a до b
если F(t) < R
то
M := t; R := F(t)
Все кц вывод R
кон
алг цел F(цел x)
нач знач := 19*(16-x)*(16-x)+27
кон
Ответ: 27

11. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках):
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -20: B = 20
M = A: R = F(A)
FOR T = A TO B
IF F(T) < R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT R
FUNCTION F(x)
F = 16*(9-x)*(9-x)+127
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 16*(9-x)*(9-x)+127;
end;
BEGIN
a := -20; b := 20;
M := a; R := F(a);
for t := a to b do begin
if (F(t) < R) then begin
M := t;
R := F(t);
end;
end;
write(R);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 16*(9-x)*(9-x)+127;
}
void main()
{
int a, b, t, M, R;
a = -20; b = 20;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) < R) {
M = t; R = F(t);
}
}
printf("%d", R);
}
алг
нач
цел a, a, b, t, R, M
a := -20; b := 20
M := a; R := F(a)
нц для t от a до b
если F(t) < R
то
M := t; R := F(t)
Все кц вывод R
кон
алг цел F(цел x)
нач знач := 16*(9-x)*(9-x)+127
кон
Ответ: 127

12. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках)
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -20: B = 20
M = A: R = F(A)
FOR T = A TO B
IF F(T) < R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT R
FUNCTION F(x)
F = 11*(9-x)*(9-x)+131
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 11*(9-x)*(9-x)+131;
end;
BEGIN
a := -20; b := 20;
M := a; R := F(a);
for t := a to b do begin
if (F(t) < R) then begin
M := t;
R := F(t);
end;
end;
write(R);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 11*(9-x)*(9-x)+131;
}
void main()
{
int a, b, t, M, R;
a = -20; b = 20;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) < R) {
M = t; R = F(t);
}
}
printf("%d", R);
}
алг
нач
цел a, a, b, t, R, M
a := -20; b := 20
M := a; R := F(a)
нц для t от a до b
если F(t) < R
то
M := t; R := F(t)
Все кц вывод R
кон
алг цел F(цел x)
нач знач := 11*(9-x)*(9-x)+131
кон
Ответ: 131

13. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках).
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -20: B = 20
M = A: R = F(A)
FOR T = A TO B
IF F(T) > R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT M
FUNCTION F(x)
F = 16*(9+x)*(9+x)+127
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 16*(9+x)*(9+x)+127;
end;
BEGIN
a := -20; b := 20;
M := a; R := F(a);
for t := a to b do begin
if (F(t) > R) then begin
M := t;
R := F(t);
end;
end;
write(M);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 16*(9+x)*(9+x)+127;
}
void main()
{
int a, b, t, M, R;
a = -20; b = 20;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) > R) {
M = t; R = F(t);
}
}
printf("%d", M);
}
алг
нач
цел a, a, b, t, R, M
a := -20; b := 20
M := a; R := F(a)
нц для t от a до b
если F(t) > R
то
M := t; R := F(t)
Все кц вывод M
кон
алг цел F(цел x)
нач знач := 16*(9+x)*(9+x)+127
кон
Ответ: 20

14. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках).
Бейсик Паскаль
DIM A, B, T, M, R AS INTEGER
A = -25: B = 25
M = A: R = F(A)
FOR T = A TO B
IF F(T) > R THEN
M = T
R = F(T)
END IF
NEXT T
PRINT M
FUNCTION F(x)
F = 15*(5+x)*(5+x)+125
END FUNCTION
var a,b,t,M,R :integer;
Function F(x: integer):integer;
begin
F := 15*(5+x)*(5+x)+125;
end;
BEGIN
a := -25; b := 25;
M := a; R := F(a);
for t := a to b do begin
if (F(t) > R) then begin
M := t;
R := F(t);
end;
end;
write(M);
END.
Си Алгоритмический
#include<stdio.h>
int F(int x)
{
return 15*(5+x)*(5+x)+125;
}
void main()
{
int a, b, t, M, R;
a = -25; b = 25;
M = a; R = F(a);
for (t=a; t<=b; t++){
if (F(t) > R) {
M = t; R = F(t);
}
}
printf("%d", M);
}
алг
нач
цел a, a, b, t, R, M
a := -25; b := 25
M := a; R := F(a)
нц для t от a до b
если F(t) > R
то
M := t; R := F(t)
Все кц вывод M
кон
алг цел F(цел x)
нач знач := 15*(5+x)*(5+x)+125
кон
Ответ: 25

15. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках):
Ответ: 28

16. Определите, какое число будет напечатано в результате выполнения
следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх
языках):
Ответ: 32


Категория: по информатике | Добавил: Админ (03.01.2016)
Просмотров: | Теги: ЕГЭ | Рейтинг: 0.0/0


Другие задачи:
Всего комментариев: 0
avatar